AppVeyor Status

Incident

Connectivity issues to nuget.org
Minor  Resolved · Jul 17, 2017, 18:01 UTC · resolved Jul 21, 2017, 01:36 UTC
Resolved
Verizon Digital Media Services (CDN service used by Azure) has routed the network path to a different ISP which fixed the issue. The reason for the packet loss on that specific link is still being investigated by Verizon.
Jul 21, 2017, 01:36 UTC
Identified
We've deployed a workaround (along with <a href="https://www.appveyor.com/updates/2017/07/19/">other changes</a>) to all three images: <code>Visual Studio 2013</code>, <code>Visual Studio 2015</code> and <code>Visual Studio 2017</code>. Let us know if you are still experiencing the issues restoring nuget packages. In the mean time we continue working with Azure, Verizon and Rackspace on a permanent solution.
Jul 19, 2017, 19:45 UTC
Identified
While working with NuGet, Azure and Rackspace teams on resolving this issue we are deploying a temporary workaround to build worker images.
Jul 19, 2017, 03:34 UTC
Investigating
The issue is a "broken" route between Rackspace data center and US-based CDN edge server for api.nuget.org. Unfortunately, there is no ETA yet. We continue working with nuget team to resolve the issue as soon as possible.
Jul 18, 2017, 04:59 UTC
Investigating
Temporary workaround is to redirect nuget restore to European CDN edge server by adding this to <code>appveyor.yml</code>:

<pre>
hosts:<br> api.nuget.org: 93.184.221.200
</pre>

If you are configuring your projects via UI you can add host mappings on "Environment" tab of project settings.

The fix above will work only if <code>nuget restore</code> command is run after <code>install</code> phase. To update hosts file <b>before</b> <code>install</code> phase please use the following solution:

<pre>
init:<br>- ps: '[System.IO.File]::AppendAllText("C:\Windows\System32\drivers\etc\hosts", "`n93.184.221.200`tapi.nuget.org")'
</pre>

Please note this is a temporary workaround that should be removed once the issue is resolved. Sorry for the inconveniences.
Jul 17, 2017, 19:54 UTC
Investigating
We are investigating intermittent connectivity issues to api.nuget.org.
Jul 17, 2017, 18:01 UTC

← Back to history